Ubuntu에 Metasploit 설치하기

Ruby 2.1 버전 이상 설치가 필요하다.

# Adds Ruby 2.2 to Ubuntu 14.04
sudo apt-add-repository ppa:brightbox/ruby-ng
# Adds Ruby v1.9/2.0/2.1/2.2 to Ubuntu 14.04/15.04
# sudo add-apt-repository ppa:brightbox/ruby-ng-experimental

sudo apt-get update
sudo apt-get install ruby2.2 ruby2.2-dev

관련 패키지를 설치하도록 한다.

sudo apt-get install bundler libpq-dev libpcap-dev libsqlite3-dev

Metasploit을 다운로드 받는다

git clone https://github.com/rapid7/metasploit-framework metasploit-framework

Metasploit 폴더경로에서 ‘sudo bundle install’ 명령어로 설치한다.

Metasploit 폴더경로에서 ‘sudo ./msfconsole’ 명령어로 실행한다!

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다